宝塔6.9.X版本BUG:无法申请签发Let’s Encrypt的SSL证书

久久鱼

发表文章数:442

热门标签

, , , , ,

目前宝塔已经更新到了6.9.2版本,这个版本有一个小BUG,就是网站无法申请新的SSL证书。提示错误如下图所示:

宝塔6.9.X版本BUG:无法申请签发Let’s Encrypt的SSL证书

一旦没有开启SSL,原本使用HTTPS访问的,会出现报错,导致流量损失。

宝塔6.9.X版本BUG:无法申请签发Let’s Encrypt的SSL证书

如上图所示,就是 Google Chrome 浏览器提醒的HTTPS报错。

这个原因是因为6.9.2版本的宝塔缺少了 requests 模块,只需要手动安装即可。SSH登录服务器,

链接上后,执行下面代码即可安装好 requests 模块.

1
pip install requests

也可以直接在宝塔面板,命令行管理执行,功能都一样。

安装好了后再去申请证书,就会提示成功。

宝塔6.9.X版本BUG:无法申请签发Let’s Encrypt的SSL证书

如上图所示,这就签发成功了,就可以正常使用HTTPS,另外还可以看到具体的到期时间。

分享到:
赞(5) 打赏文章 生成海报

长按图片转发给朋友

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

Vieu4.0主题
专业打造轻量级个人企业风格博客主题!专注于前端开发,全站响应式布局自适应模板。
切换注册

登录

忘记密码 ?

您也可以使用第三方帐号快捷登录

Q Q 登 录
微 博 登 录
切换登录

注册